Lilly of the Valley lacking blooms

penguu(8)May 11, 2012

I have some Convallaria in an 8" pot. There are about 20 plants. The leaves are very large and look healthy but I only have 2 flower stalks. What is the problem for the lack of bloom?

Am I overcrowding the plants in a too small pot? Did I get bulbs that were insufficiently fertilized the previous year? Or is it a matter of time, that more flowers will come?

Thank you for reporting this comment. Undo
vetivert8(NI-NZ zone 9a)

Sounds like overcrowding and, perhaps, not enough food.

Maybe three to an eight inch pot. Topdress with good compost and well-rotted or pelletised animal manure (steer, horse, or sheep but not chicken because it can be too 'hot' and alkaline.) And - cover with oak leaves in winter.

Morning sun up to about 10am could be useful, too.

Repot every year if they are going to stay in a small-ish pot.

    Bookmark   May 16, 2012 at 3:22AM
Sign Up to comment
More Discussions
Unsure what to do with cyclamen
There are a lot of cyclamen posts but none seem to...
cosuperfly
Please identify?
My son has these growing in his front lawn. I don't...
gardenbug
Will fertilizer seep through mulch?
This is my first season in a new home in coastal South...
Ralph Thayer
Please Help! Can I plant allium bulbs in the spring?
Hello all, I just found this website yesterday and...
midwestplantsfan
Experience with Ordering from Brecks or Royal Dutch Catalogs??
Has anyone ordered spring flowering bulbs from either...
bobk_stl
© 2015 Houzz Inc. Houzz® The new way to design your home™