Strange Allium flowers

toni-louJuly 9, 2008

I bought an ornamental Allium plant last year that was already flowering (purple standard size). I planted it in my garden & it died off & grew back this year, plenty of growth, buds etc. But when the buds opened there were no purple flowers, just green small spheres, almost as if something has sucked the flowers off! I thought maybe the purple flowers grow later, so left them but it's now been 2 weeks & they haven't changed. Can anyone explain what is going on please. Am I just being dumb??!

Thank you for reporting this comment. Undo
honeybunny442(z6 TN)

That is strange, wish you had a picture! Could it be possible you missed it flowering? The small green spheres sound like seed pods, left after flowering.
Then again, sometimes Alliums are very slow to open, especially if it is dry.

    Bookmark   July 30, 2008 at 9:47AM
Sign Up to comment
More Discussions
How to plant Crinums with leaves
Hey all, Just received some mail order crinums which...
jscaldwell
spreaders
pushkinia, scillas, aka chionodoxa, muscari. what nice...
daves10z7annv
Poll: share what is blooming for you!
My brother in Zone 8 has daffodils blooming! What...
posierosie_zone7a__
Recommendations for mainly crocus bulb supplier
Short story: New house, few bulbs (almost none) I'd...
dbarron
forgot to plant bulbs- now they're sprouting- what can I do?
Hi I realise this question has already been asked but...
dysphorea
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™