Streptocarpus problem.

SusanJNYJuly 19, 2012

I purchased this plant from Logee's several months ago. It had some of these yellow spots that have now worsened. I have tried extra fertilizer, and varying the light/moisture level, but they keep getting worse. And I am also starting to see them on the Streps I've had for years. Any ideas?

Thank you for reporting this comment. Undo
pirate_girl(Zone7 NYC)

Hi Susan,

Sorry I don't know these plants except to say they are in the Gesneriad Family & that GW does have Gesneriad Forum (see top of from page here). Am guessing if you post there, you'll get some reasonable suggestions.

Until then, if you think this plant is the source, pls. consider moving it well away from the rest of your collection so it doesn't spread further.

Pretty Plant & Good luck!

    Bookmark   July 20, 2012 at 12:12PM
Thank you for reporting this comment. Undo
tommyr_gw

Hmmm, never seen this before on my few Streps. What fertilizer are you using? How much light do they get.

    Bookmark   July 20, 2012 at 2:46PM
Sign Up to comment
More Discussions
What is this?
Noticed today that my 'perfect' Spider plant of the...
MrBlubs
Diatomaceous Earth vs. Fired Clay in Gritty Mix
I've seen Napa Floor-Dry (8822), which is diatomaceous...
kwie2011
My Calathea is blooming - hehe
Flowers look pretty good!
jujujojo_gw
March Flowers
I feel guilty posting this as teen usually does but...
MrBlubs
Moisture Meter?
I have a mechanical moisture meter, and it has increasingly...
trclac
© 2015 Houzz Inc. Houzz® The new way to design your home™