Craftsman 21' self propelled won't restart

conpewterApril 26, 2008

Hello!

I have a very weird issue with the mower. I bought it used and it's always done this.

It starts up just fine (One pull after a winter of storage...) after using the priming bulb of course. It will run forever until it runs out of gas, just fine. However it won't restart unless you let it cool down for two hours.

Any ideas what may be causing this?

Thank you for reporting this comment. Undo
bill_kapaun

Check the quality of the spark when cold vs hot.
Don't run it out of gas. Maybe the carb has trouble filling for some reason when empty.

I had an OLD Craftsman years ago that was terrible hot starting. It was probably a bad coil, but if I replaced the spark plug about every 5 hours, it was "bearable".

    Bookmark   April 26, 2008 at 3:26PM
Thank you for reporting this comment. Undo
rdaystrom

My theory is that your ignition coil assembly is failing after you shut it off by heat soaking. When it cools down it works again. I haven't seen the much talked about "vapor lock" syndrome but some people may suggest that. I vote for a marginal ignition coil assembly. I have so many mowers with marginal ignition coils. If it's cold, wet, or sometimes too hot they won't fire. That's the reason people traded them in I'm sure. If all mowers had a strong reliable spark like today's cars we might be amazed how reliable and easy to start they would be. Anyway.... Do a bit of diagnostics. Next time it won't start quickly pull the spark plug connect it to the wire and lay the plug on the cylinder fins. Have someone pull the rope with everything in the start position and you watch for a spark. (watch out for your toes around that blade) A good spark should be blue on a clean plug. If no spark while it's still hot then I say the coil is bad. If it does spark try a new plug. If it sparks good but doesn't start try a squirt or cap full of gas down the intake to see if it will start momnetarily. If the manual priming test doesn't get it going make sure it has compression. Possibly a valve is sticking when it's hot but I kinda doubt it.

    Bookmark   April 26, 2008 at 3:30PM
Thank you for reporting this comment. Undo
conpewter

I bought a new spark plug and had my wife pull the cord (this is after I ran it for a little while and shut it off) There is no spark so I'm going to order a new ignition coil for it and give that a try. I'll report back, Thanks!!

    Bookmark   April 26, 2008 at 9:10PM
Sign Up to comment
More Discussions
Lawn-boy F Series - Connecting Rod play ?
I have my Lawn-boy apart to replace upper and lower...
bhap
Best self propelled walk behind mulching mower
Hey Guys and Gals, in the market for the best all around...
mowman07
Toro 22" Recycler can't get it started! Please help!
Hi Everyone, So I inherited a 6 month old Toro 22"...
enigma7
Honda Mower Problem-Backfire thru Carb?
I have a Honda walk behind that has been awsome until...
jteekell
Charger for/charging a Toro GTS 6.75 hp
I recently acquired a several year old Toro GTS 6.75...
bkay2000
Sponsored Products
Edge Vinyl Office Chair in Red
$140.00 | LexMod
ION Design | Cora Small Credenza
YLiving.com
Athena Alice 3 in 1 Convertible Crib - Espresso - 4689E
$249.00 | Hayneedle
Fairmont Designs Prairie 36" Vanity - Cognac
Modern Bathroom
Salt Chair
Design Within Reach
Bedside Lamps: Cathrine 1 Light 21 in. Polished Chrome Table Lamp CLI-DN14004329
Home Depot
Ink Blot Side Chair
$479.99 | Dot & Bo
Battery Operated Outdoor Twig Tree - 3'
Grandin Road
© 2015 Houzz Inc. Houzz® The new way to design your home™