Toro 20333 misfires when blade disengaged

zarichJune 21, 2010

I have a new toro 20333. When I release the blade lever the mower idles and makes a popping noise repeatedly and shakes a bit (though not hard). I took it to the local service guy and he thought it might be normal for this mower because they use a very small fly wheel. When the blade is engaged it runs great. However, the misfiring when idling seems wrong to me. Can any give me advice?

Thank you for reporting this comment. Undo
baymee(LehighValleyPA)

Snowblower engines do the same. If it works well under a load, that's all I would worry about.

    Bookmark   June 21, 2010 at 9:23PM
Thank you for reporting this comment. Undo
rckowal

I have the Toro 20334, which I believe is the 2010 model - 20333 was 2009. Mine runs smooth, free of back-firing at any time.

Regards, Richard

    Bookmark   June 25, 2010 at 1:22PM
Thank you for reporting this comment. Undo
zarich

20334 does not allow you to stop the blade without stopping the engine only the 20333 does this.

    Bookmark   June 25, 2010 at 7:22PM
Sign Up to comment
More Discussions
Tru-cut Reel Clutch Adjustment
I've owned this guy since new (1979). Beyond normal...
runner70
Need Craftsman mower grass bag
I have a very old, but really good condition Craftsman...
olddaddy
New Purchase
Well hard to believe that it took over 25 yrs to breakdown...
ewalk
Briggs and Stratton spark plug confusion
I've got a B & S opposed twin 422707 on a Craftsman...
yt125
New Toro Push Mower?
I am looking to replace an 11 year old Toro Recycler,...
seashells18
© 2015 Houzz Inc. Houzz® The new way to design your home™