Help with starting Mower

Corky71(7)June 27, 2014

I have a craftsman 917370431. Mower is 1 year old. It pretty much has started on 1 pull since day 1. A couple of days ago I replaced the blade as per directions. When I started it it started to make a clunking like sound, almost like the blade was loose. I stopped it immediately and tightened up the blade bolt as much as I could. When I went to start it again it wouldn't start at all. Thinking I may have flooded engine from tilting the mower I waited a day and tried again but mower still isn't starting.

Anybody have any ideas as to what could have gone wrong? Thanks in advance.

Anthony

Thank you for reporting this comment. Undo
bill_kapaun

IF you tipped it over with the carb side down, you probably saturated the air filter with oil.

    Bookmark   June 27, 2014 at 7:02PM
Thank you for reporting this comment. Undo
Corky71(7)

Thanks Bill. Actually when I removed the blade again I noticed the star center of the blade adapter had broke and it's unable to keep the blade tight. If I replace the adapter do you think it would fix the problem or did I likely cause more damage?

    Bookmark   June 29, 2014 at 11:25AM
Sign Up to comment
More Discussions
B&S OHV 6.5 won't start
If I prime the engine 5/6 times it starts on the second...
mvron
Looking to replace the LB
I've been using a 2003 Lawnboy 10323 for over a decade...
pacochu
Craftsman ZTS 7500
Going to look at a used one of these tomorrow. Anything...
radlee30458
john deere RX75 belt diagram
I have a Rx75 with 9hp motor. I bought it used and...
jeremy_2010
Craftsman Lawn Mower Model#917258860 won't turn left
I just bought a Craftsman Lawn Mower with a 46"...
russph3
© 2015 Houzz Inc. Houzz® The new way to design your home™