Briggs & Stratton series 500 engine speed

dtpimaJuly 2, 2013

The engine speed is regulated as usual when not cutting, but the speed drops as soon as cutting starts, and only recovers very slowly - I suspect the governor?

Thank you for reporting this comment. Undo
bill_kapaun

I suspect a clogged air filter.

    Bookmark   July 2, 2013 at 10:44AM
Thank you for reporting this comment. Undo
dtpima

Thanks Bill, but that was the first thing I checked!
Any idea where I can get a service manual?

    Bookmark   July 2, 2013 at 10:48AM
Thank you for reporting this comment. Undo
1saxman

Could be low compression/worn out/head gasket leak. Also could be running lean/clogged carb or fuel supply.

    Bookmark   July 2, 2013 at 1:36PM
Thank you for reporting this comment. Undo
bill_kapaun

Did you replace the air filter or "just check" it?
A filter can "look" clean, but be clogged with ultra fine particles.
I've ran into that issue with my old Honda. Ran fine, but just didn't seem to have the power in the thick stuff
It simply couldn't gulp enough air when the governor opened up the throttle valve.

This post was edited by bill_kapaun on Tue, Jul 2, 13 at 14:37

    Bookmark   July 2, 2013 at 2:27PM
Thank you for reporting this comment. Undo
dtpima

I just checked it! I'll take the filter out and see what happen. The machine is only 3 years old, and has only run for about 25 hours.

    Bookmark   July 2, 2013 at 3:10PM
Sign Up to comment
More Discussions
JD L100 and LA100 series trans oil change
I have a JD L118. It had a K46 trans that failed at...
fix_it
Mclane 20" mower at Sears... why so inexpensive?
Hey everyone, I want to get yall's input on a mower...
bobbarker14
Snapper commercial refurb
This is the 1986 snapper 21500PC that I found in the...
snapperfreak
john deere RX75 belt diagram
I have a Rx75 with 9hp motor. I bought it used and...
jeremy_2010
John Deere L110
The mower has been sitting for 3 years, it ran when...
paddlingjohn
© 2015 Houzz Inc. Houzz® The new way to design your home™