Lawnboy Cylinder Head Pics

weed_cutterAugust 10, 2014

Model 10324 with 2 stroke Duraforce engine. Head gasket was leaking. Engine ran fine, only symptoms were a little harder to start and I could hear a wheeze when pulling the starter rope. I rebuilt this engine about 6 years ago and estimate more than 250 hours on it since the rebuild. Fed a regular diet of pump gas and 32:1 Mobil One 2T until I switched to Castrol RS TTS about 2 years ago, also 1 oz of Seafoam/gal.

Is the cleanliness of head due to the engine's diet or the result of the gasket leak? Maybe this is normal but I was a little shocked.

Thank you for reporting this comment. Undo
weed_cutter

Here's a pic of the top of the piston.

    Bookmark   August 10, 2014 at 4:41PM
Thank you for reporting this comment. Undo
1saxman

Looks to me like you're doing it right, resulting in a clean-running engine. The plug does not look like it has been subjected to a lean mixture at all. You can credit the use of premium oil and the Seafoam for it.

    Bookmark   August 14, 2014 at 10:39PM
Sign Up to comment
More Discussions
Craftsman 6.6 Eager 1 917.377321 won't stary running
The only way I can keep this mower running is to take...
fresno99
2 cycle (Robin) Snapper
Does anyone have any input on whether that Robin 2cycle...
wegrowhair
Two-cycle Lawnmower for Hills?
My lawn was hilly before, but recently became more...
fritz1255
Charger for/charging a Toro GTS 6.75 hp
I recently acquired a several year old Toro GTS 6.75...
bkay2000
Bolen mower
I have a 2010 Bolen model: 13WC762Fo65/ 317737/ 38"...
Scott Walker
© 2015 Houzz Inc. Houzz® The new way to design your home™