pto on swisher will not engage

ksuwildcatsAugust 9, 2013

I have a 2/3 year old swisher zero turn mower model zt2452a. I was cutting grass 2 days ago and the grass was high and wet. The blades started to bog down and the blades stop turning. Now the pto will not turn on . There is a very poor schematic in owners manual That I cant make out. I looked on the mower and found a 30 amp fuse and tested it and its fine.Any thoughts on what to check next ? Thanks Roger

Thank you for reporting this comment. Undo
Basementgeek

Going to have to check for voltage both going into and out of the fuse. Check for voltage at the clutch.

BG

    Bookmark   August 10, 2013 at 7:26AM
Thank you for reporting this comment. Undo
bill_kapaun

This may not be your brand clutch, but the trouble shooting should be similar-

http://www.warnernet.com/pdf/819-0458_P-1097-6.pdf

    Bookmark   August 10, 2013 at 12:06PM
Thank you for reporting this comment. Undo
ksuwildcats

Thanks for the help. What i did today was go out and turn the pto switch on and off a few times and it starting working again. Im thinking the switch might be on its way out. I have only had this mower about 3 years and it sits out side year around , but get covered in winter. Thanks again BG and Bill

    Bookmark   August 10, 2013 at 9:16PM
Sign Up to comment
More Discussions
Bad ignition coil magneto on Tecumseh
Is there a more economical solution to replacing a...
don_v
Engine trouble! B&S 13.5hp
My old Heritage ride-on has a Briggs& Stratton...
Over_here
Mclane 20" mower at Sears... why so inexpensive?
Hey everyone, I want to get yall's input on a mower...
bobbarker14
I have a Tecumseh 5hp egine no spark
I measure the ohms from the following. I placed one...
Nutty1269
JD L100 and LA100 series trans oil change
I have a JD L118. It had a K46 trans that failed at...
fix_it
© 2015 Houzz Inc. Houzz® The new way to design your home™