Simplicity Hydro issue

smatloff(z5 N.H.)November 24, 2011

Hi Everyone,

Here is my issue. I have a Simplicity 12.5 LTH. Sometimes when I try to go forward it doesn't move. I can back it up and then it works. Other times as I try to go faster, it slows down and stops moving. Again, I can just back it up and get it going again, but only at slow speeds. The fluid is up to the cold full line when cold. Any ideas?

Thank you for reporting this comment. Undo
tomplum

Here's what I wrote last time in case you missed it. First check the exterior variables. Be sure that the brake arm isn't sticking at times. A touch of well placed spray lube on the back of the arm is sometimes enough to help. That is fairly common when someone has to change direction to rectify things. It won't necessarily just stop the machine with no input from the pedal however. If the pins that push the pads against the disc are binding, it can as it warms create more drag however. Beyond that, you'll need to know that the condition of the drive belt is good and not worn thin or worse and that the linkage from the hydro control to the transaxle is secure. ***Let us know what you find.***

    Bookmark   December 1, 2011 at 9:36PM
Sign Up to comment
More Discussions
Craftsman Lawn Mower Model#917258860 won't turn left
I just bought a Craftsman Lawn Mower with a 46"...
russph3
Looking to replace the LB
I've been using a 2003 Lawnboy 10323 for over a decade...
pacochu
Champion Spark Plug lack of quality
Picked up a set of RJ12C's to have on hand when I do...
yt125
John Deere L110
The mower has been sitting for 3 years, it ran when...
paddlingjohn
Craftsman ZTS 7500
Going to look at a used one of these tomorrow. Anything...
radlee30458
© 2015 Houzz Inc. Houzz® The new way to design your home™