i didnt winterize my troybuilt pressure washer!

nick46304March 21, 2010

So i deployed to afghanistan at short notice around october last year, and i just got back.. i had some time off so i wanted to clean the cars.. when i got the pressure washer out and starting using it... i wasnt getting any pressure at all. and i noticed that the water comming out was extremely hot.. the motor was heating up real bad... so i took the pump off and looked to see if i saw anything in there. i didnt see anything clogging or anything, but i just cleaned it up a little bit and put it back together. still no pressure... when i let it run for a min or so, and then press the trigger it would have a little pressure built up but then thats it..

So if anyone knows what i might have to do or replace that would be great!@ Thank you Its a troybuilt with a honda gcv 160 on it. only a year old!

Thank you for reporting this comment. Undo
canguy(British Columbia)

If you have it hooked to cold water as you should, you needed to run it for a while to get the water that hot. That suggests the unloader valve is stuck probably due to mineral buildup. It may or may not be repairable, many axial pumps are now throw away with no service parts. I hope you didn't leave it with water in it where it could freeze.

    Bookmark   March 21, 2010 at 4:06PM
Thank you for reporting this comment. Undo
nick46304

the thing is i didnt run it for more than like 5 min and the water was reallly hot. what does the unloader valve do? i noticed water comming out of the bottom out of somekind of small outflow. ive never seen it come out of before

    Bookmark   March 21, 2010 at 10:04PM
Thank you for reporting this comment. Undo
nick46304

the thing is i didnt run it for more than like 5 min and the water was reallly hot. what does the unloader valve do? i noticed water comming out of the bottom out of somekind of small outflow. ive never seen it come out of before

    Bookmark   March 21, 2010 at 11:33PM
Sign Up to comment
More Discussions
Craftsman Snow Blower - Drive problem
During our big storm last week i noticed I started...
rspin
Kohler K181 valve clearance
The engine would run perfect for maybe 30-45 minutes,...
snuffyinatl
Any Good Electric Brushcutter?
I have a small area, my lot is just 1/2ac and less...
InFlux
2 stroke Mantis tiller vs. 4 stroke Mantis
I'm looking at buying a small Mantis cultivator but...
lil_rhody
Primer not getting Gas?? After Carb Rebuid?
I just rebuilt a couple snow blower Carbs (both Tecumseh...
bertman_gw
© 2015 Houzz Inc. Houzz® The new way to design your home™