Tecumseh TCII Troy Built mini-tiller won't start

jjacobwestonApril 25, 2007

I'm having trouble starting my old TCII tiller. It hasn't been started in a few years, so I guess I wasn't that surprised when it didn't start. I've filled it with some 24:1, checked the spark plug and tried hardwiring the switch-cutoff in case of a bad switch, but it still doesn't seem to be starting up. Any suggestions on what to do with it, short of taking it in for repair?

J.

Thank you for reporting this comment. Undo
canguy(British Columbia)

Remove the air filter and shoot a spritz of gas, NOT starting fluid, into the carb. If it fires and quits, your carb is gummed up and needs overhaul.

    Bookmark   April 25, 2007 at 1:13PM
Thank you for reporting this comment. Undo
bill_kapaun

Here's a link for the service manual-
It seems to be a bit flaky at times, so if it doesn't work now, try again at a later time.

Here is a link that might be useful: TC Manual

    Bookmark   April 26, 2007 at 4:59AM
Thank you for reporting this comment. Undo
mla2ofus

You said you "hardwired the switch". What do you mean? If a switch is suspect,I disconnect it as it grounds the coil to kill the spark.
Mike

    Bookmark   April 26, 2007 at 8:28AM
Sign Up to comment
More Discussions
Mantis tiller will not idle
Picked up a used Mantis (SV-4/A engine) that will just...
ccarlsonnh
Troy Bilt Horse Drive Shaft Bearings
I took my horse apart because the front transmission...
gildomilo
Sears air compressor engine won't run when plugged in
Sears Paint Sprayer/Air Compressor Model No. 106.153542...
Cletus77
Primer not getting Gas?? After Carb Rebuid?
I just rebuilt a couple snow blower Carbs (both Tecumseh...
bertman_gw
Any Good Electric Brushcutter?
I have a small area, my lot is just 1/2ac and less...
InFlux
© 2015 Houzz Inc. Houzz® The new way to design your home™