Echo Trimmer

ichabod(z8GA)April 13, 2013

Working on an Echo GT-2000 string trimmer. Rebuilt the carb last season and it was running good then. Now it won't fire. Tried a new plug and tried a small amount of fuel straight into the throat of the carb. Compression is 125 psi. Also regapped the coil to 0.07 inch. The spark will jump a 0.25 inch gap, but very weak and yellow compared to my Stihl trimmer. I'm inclined to replace the coil but not sure if the cost is worth it because I don't know what a new, equal trimmer would cost. The 2000 must be an older model. What would you do?

Ichabod

Thank you for reporting this comment. Undo
ichabod(z8GA)

Oops, should have been 0.007 inch gap.

    Bookmark   April 13, 2013 at 6:28PM
Sign Up to comment
More Discussions
Craftsman Snowblower Recall
Did anyone else receive a recall notice in the mail...
pjrsjr
No more roll pins
Finally got the roll pins out of the wheels on my Horse...
snuffyinatl
Testing the new format X allowing multiple attachments.
I am back to two Lexan chain guides due to a chain...
loger_gw
Electric shredder motor will switch on but won't spin the blades
Hello, I have an electric garden shredder that will...
Lindsay Durdle
2-cycle engine troubleshooting
My 2-cycle blower cannot be started. There is a hot...
slim50
© 2015 Houzz Inc. Houzz® The new way to design your home™