troy bilt horse w/ greyhound engine dies?

jody777May 9, 2010

I have an older 2 spd horse, and read somewhere about the harbor freight greyhound engines, so I got one. It runs fine, but when I till deep it cuts off? Is this the low oil shut down? I can level it off and it starts up again, only to go 20' and die again. It works fine on a shallow 4" till. I know you add gear oil thru the handle screw, but do you just add enough to the second plug on the side of the trans? I think I put in too much, it seems to come out the top screw by the pulleys. Thanks

Thank you for reporting this comment. Undo
gator_rider2(z8 Ga.)

Try few things on engine add oil about 2 oz over full other thing run engine half speed there couldbe to much windage in oil so sling off switch depth guage in 4th notch it be better to go over ground 3 times than run engine if soften ground in one pass next pass tires sink in soil be less tilt on engine. A lot old engine was run dry oil thats what got in state need replacing now have tilt switch so evidents is tilting engine to much.

    Bookmark   May 9, 2010 at 8:07PM
Sign Up to comment
More Discussions
Toro 826 Drive Belt Jumps Off Crankshaft Pulley
Hello, I have a nine year old Toro Powermax 826. Late...
ronpr2112
Primer not getting Gas?? After Carb Rebuid?
I just rebuilt a couple snow blower Carbs (both Tecumseh...
bertman_gw
Sears air compressor engine won't run when plugged in
Sears Paint Sprayer/Air Compressor Model No. 106.153542...
Cletus77
Kohler K181 valve clearance
The engine would run perfect for maybe 30-45 minutes,...
snuffyinatl
Best gas leaf blower?
Can anyone recommend a good gas powered leaf blower?...
robar
© 2015 Houzz Inc. Houzz® The new way to design your home™