Craftsman Riding Mower blades won't engage

Donna560April 2, 2012

I have a craftsman 917.256501 riding mower. Newly tuned up but when I try to engage the mowing blades nothing - no sound no movement.

I have checked belt - good and in order

checked mandrels - moves freely

I watched the clutch as the lever was moved from disengage to engage (tractor was off) and all seems good.

I can manually move the belt so what is left?

I have electrically checked the seat kill switch and that functions

Thank you for reporting this comment. Undo
rcbe(6)

After again verifying that mower drive belt is routed inside all belt guides and engaging all pulleys (see manual), make sure that Deck clutch rod and lever are assembled together with spring retainer in place.
Start engine, engage mower. Deck blades should begin operating. If not, re-check all pulleys to turn freely with no slop.
Also - with engine off - engage mower and check to see that belt is tensioned. If not, belt stretched or mower clutch mechanism faulty or needs lubrication.
If needed, see link below for downloadable manual.

Here is a link that might be useful: manual

    Bookmark   May 18, 2012 at 2:17PM
Sign Up to comment
More Discussions
Just throwing this out there...
Been thinking of starting a Facebook page on small...
snuffyinatl
Does anyone else have this problem?
I have a Craftsman riding mower that the manual clutch...
cowgirlrose55
Can you identify this Muffler?
I obtained this muffler a while ago, but have no idea...
rodco
John Deere 445 EFI wet plugs
Tractor won't start until you remove both spark plugs and...
stone75
Help! I'm in Safety Switch Hell
Craftsman Model# 917.272030 Engine stalls with clutch...
biggestdaddyo
© 2015 Houzz Inc. Houzz® The new way to design your home™