1986 Troy Bilt Pony Tiller Stalling

gypsum7777July 10, 2013

I have a 1986 Pony Tiller. It has been in the family and it has not been ridden hard. Now, last year the unit started stalling under load after it warmed up and then I started using it. So, I was finished and let it sit until March/April of this year. I tried again and I could not get more than dew feet completed before it stalled again. So, I replaced the jet and fuel pump bladder (Pulsa-jet carb) and then cranked it; started right up; adjusted it and walked it around the yard back and forth, then started to till and it started to stall again; tried reverse and it stalled again. I read about checking the fuel cap; that is okay; checked for sparkl; that is okay; cleaned the valves; that is okay; checked the ignition coil for damage; that is okay; checked the muffler; that is okay; clean, new fuel; that is okay. Now, I wonder about two things: 1) Is the age of the coil (1986) and heat the problem? or 2) Will the belt tension effect the stalling? I think I installed a new belt at some point (last year? mind is going)) but, is there a check for the belt tension (no OP manual on hand)? I believe the engine is fine and carb is okay. The old diapraghm was hard after 27 years and i thought I solved the stalling, but it continues. Thank you for some insight. Gyp

Thank you for reporting this comment. Undo
bill_kapaun

Check the tank for crud blocking the pick up tube.

    Bookmark   July 11, 2013 at 12:59AM
Thank you for reporting this comment. Undo
gypsum7777

It is clean. I have run thru tank after tank recently running this thing for testing and then letting it sit and idle; then I engage then it stalls under load. I was thinking that the throttle linkage might be adjusted to high of RPM such that when I engage the tines that is craps out because the govnr kicks out. Is this possible? I can readjust the throttle such that the engine is not high speed. I might have adjusted so that it is too high rpm??? I did recheck the gas cap and it is clean. I did make sure that the ign module did not have wire touching ground...The oil is new and it is within sight of the filler hole (thought I might have ovefillled)

    Bookmark   July 11, 2013 at 10:28AM
Thank you for reporting this comment. Undo
gypsum7777

I went out and looked at the pony and read some more about gov and linkage and then thought that this thing has not been abused and it is very simple and should run underwater. So, I took off the gas tank for the umpteenth time and actually emptied it and then looked with a flash light way in the back and I found some varnish on the side about and inch or so up. More than I expected. Sort of like the tiller sat at an angle and the last bit of fuel sat in a dip. So, I dump some carb cleaner and scrubbed with wire brush and then used a dremal with a flexextender and a wire brush and worked at it and now it is shiny and clean. I also wired a couple other spots and shined up the upper bowl as well. When I was finished I flushed with clean fuel and emptied. The fuel was cloudy, could not see thru. I will let dry and blow it out with air and get the fine left over particles out and try again. I hope it is as simple as this. I cleaned the pickup tubes, again! Let you know what happens tonite. Gyp

    Bookmark   July 11, 2013 at 2:39PM
Thank you for reporting this comment. Undo
bill_kapaun

You might want to remove the diaphragm from the carb and using the tube of your aerosol carb cleaner, blast through them.
One goes into the carb venturi and the other goes to the pick up tube. You can "back flush" that one.

Some years back, I had a rusty tank.
Blowing through that hole would unclog things for a short time, until the tank was "fixed".

    Bookmark   July 11, 2013 at 4:08PM
Thank you for reporting this comment. Undo
gypsum7777

SUCCESS TONITE! I cleaned the tank and put the entire unit back together as it was all over the floor and put in fresh fuel and it started. I trimmed it our a little bit and started right into the tilling clay. It never once stalled on me. I even gave it a good low height and it bogged down but it kept tilling. This was so good! Now I need new tires. These are 27 yrs old and lose air all of the time. But, this thing is back to where I need it to be and I just need to adjust the carb a tad bit. This was my Pops and I really wanted to fix it. As an aside I fixed my truck window and wiring problem over the weekend; then I had to throw away an 11 yr old johh deere trimmer and 25 yr old bench grinder. They crapped out. Then I needed a new magneto for the Stihl trimmer. Then I tried the tiller and just fell down laughing at the whole darn thing. I do have a Tomahawk C/S and it always starts, but I need to replace a dry rot fuel line. Then I will have all units in working order. Thanks for the tip! Gyp

    Bookmark   July 11, 2013 at 7:03PM
Sign Up to comment
More Discussions
Poulan Pro rear tine tiller, burnt valve??
I have a 6.5 Intec Briggs on my tiller, which is 10...
slowpoke_gardener
Electrolytic Rust Removal
Has anyone tried this, using a battery charger, "washing...
exmar
2-cycle engine troubleshooting
My 2-cycle blower cannot be started. There is a hot...
slim50
Best gas leaf blower?
Can anyone recommend a good gas powered leaf blower?...
robar
Predator 212cc Engine, Harbor Freight FYI
Hi Folks, Been thinking of getting one of these for...
exmar
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™