Stihl Kombi KM130

zoulasAugust 10, 2011

Hello, Just purchased this item. It has about 10 minutes of use so far. Love it in every way so far. My only concern is that the engine runs super smooth from 0-50% throttle. From 50-90% there is a small vibration, from 90-100% there is a bit more. Is this normal? Why would the engine run smoother at lower RPM's. You can even see the head unit shaking a bit at higher RPM's (close to 100% throttle) I am not convinced there is anything wrong with it, I think it mat be the fact its a single cylinder engine. Any feedback would be appreciated. Thanks, Aristole Zoulas, Warwick, NY

Thank you for reporting this comment. Undo
ewalk

Vibrations within trimmers usually lend themselfs to loose or improperly aligned power heads or shaft / cable components . Ensure yours is installed correctly and all fasteners are tight , including the powerhead along with adequate lubrication of shaft .

    Bookmark   August 11, 2011 at 12:42AM
Sign Up to comment
More Discussions
IS it ME ? OR is this site/Forum Gone in hibernation?
This used to be such an informative and active site!!...
bertman_gw
Any Good Electric Brushcutter?
I have a small area, my lot is just 1/2ac and less...
InFlux
Stihl vs. Husqvarna Chainsaw purchase
I am lucky enough to have my wife ask me to pick out...
virginiacowboy
Craftsman Snowblower Recall
Did anyone else receive a recall notice in the mail...
pjrsjr
Snowblowers and engine choices - Ariens vs Toro vs Simplicity and
I live on the shoreline in CT, where we get anywhere...
bfguilford
© 2015 Houzz Inc. Houzz® The new way to design your home™