pressure washer dilemma

jr53August 10, 2013

I have a Excell xr2600 pressure washer. Engine runs fine. Attach water, pressure hose and wand - turn on water -everything runs fine. Water comes out of pressure hose/wand ok. Add any size tip (smaller than a soap tip) to the wand and the pressure washer will run and spray full power for about 5 - 10 seconds then lug down as if gas starved and die. Re-starts and will run fine until the trigger is pulled - then 5 - 10 seconds and stop.This will happen forever. Spent many hours troubleshooting the unit including a full carb cleaning and unloader valve cleaning but haven't had any luck. Any ideas?

Thank you for reporting this comment. Undo
Gav104

Ah it sounds like you might have a problem with either the fuel filter or more than likely the engine speed throttle.

Read down to the last bullet point on the first section where it talks about gas engines on this link.

Let me know if this works or not.

Good luck

Here is a link that might be useful: Tips for pressure washer engines.

    Bookmark   August 10, 2013 at 11:38PM
Sign Up to comment
More Discussions
Testing the new format X allowing multiple attachments.
I am back to two Lexan chain guides due to a chain...
loger_gw
Craftsman Snow Blower - Drive problem
During our big storm last week i noticed I started...
rspin
Any Good Electric Brushcutter?
I have a small area, my lot is just 1/2ac and less...
InFlux
Stihl vs. Husqvarna Chainsaw purchase
I am lucky enough to have my wife ask me to pick out...
virginiacowboy
Snowblowers and engine choices - Ariens vs Toro vs Simplicity and
I live on the shoreline in CT, where we get anywhere...
bfguilford
© 2015 Houzz Inc. Houzz® The new way to design your home™