Weathermatic.. possible bad SLMx modules?? Blowing fuses

bans25October 6, 2013

SL1600 with one SLM4 and one SLM12 worked great for years, then went out. Found transformer was bad. Replaced transformer and unit powered for about 20 seconds, Second transformer went bad. Replaced the SL1600 with a new one, unit powered up for 5 seconds and went out. Saw that newer SL1600 has an in-line fuse after transformer. Pulled SLM modules out and swapped fuse, unit powers up fine. Put in old SLM4 module (no wires attached) and fuse blew again. Is it possible storm blew out the SLMx modules?? Has anyone experienced this?
I have to get a couple more SLMx modules to try to get this working.

Thank you for reporting this comment. Undo
lehua49

ban,
I would suggest a dialogue with an electrical expert that knows how to test for resistance and current. Does the controller display any troubleshooting codes? What is the controller doing when you say you are powering it up. Are you trying to run any zones or just watching it turn on? Aloha

    Bookmark   October 8, 2013 at 10:17PM
Sign Up to comment
More Discussions
Best well pump for drip hose irrigation
I am trying to find some information on selecting a...
srbasile
Problem valve
Hi, I have got a problem with my newly installed irrigation...
cozbell93
Greenhouse irrigation advice
We are planning to build a 13'x'30' greenhouse in the...
rogerius
Irrigation Outage
Had a power outage at my home. I reset the GFI switch...
mchidiac
drip irrigation design
I ran 2 pipes around my property for drip irrigation....
jimmy21
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™