18 horse b&s twin cylinder no spark

jasonsford77August 21, 2010

hi i have a b&s 18 horse twin cylinder and i have no spark. replaced coil. still no spark. plugs are good. set gap on coils with buisness card. no spark. no points under flywheel just the big round magnet thing cant think of its name at moment. ? is. is there anything else on here that can cause no spark? i even unplugged the earth wire from coil still no spark. is there a way i can check coil with meter? also the guy i got it from said he replaced the starter is it possible to get a starter that spins the engine backwards? it cranks good and fast like it should ? there is what way is it sposed to spin. any help would be great thank you. jason

Thank you for reporting this comment. Undo
walt2002

This sounds strangely like a post that was on one of the forums a couple of months ago. Fist off, there are several 18 hp B&S engines and even twins. I am guessing yours is a 42 series.

There are only two things involved in making a spark when you have the "earth" wire, ground wire unplugged and those are the coil and the flywheel.

Are you sure you put the coil on right side up? The spark plug wires exit the coil towards the back of the engine, make a loop and come back under the coil and out the Intake Manifold side of the engine.

Walt Conner

    Bookmark   August 21, 2010 at 8:22AM
Thank you for reporting this comment. Undo
walt2002

"said he replaced the starter is it possible to get a starter that spins the engine backwards?"

Forgot to answer this. You can get the starter to run backward by connecting it backward HOWEVER, the starter drive would not engage. Engine turns clockwise looking at the flywheel.

How are you testing spark?

Walt Conner

    Bookmark   August 21, 2010 at 8:28AM
Thank you for reporting this comment. Undo
mownie(7)

Jason, please look on your engine and find the model number, and the type number. Post both numbers so we can know which engine we are dealing with. Briggs makes a few different engines that are "18 HP twins".

    Bookmark   August 21, 2010 at 11:49AM
Sign Up to comment
More Discussions
John Deere 425 pto not working
I bought this tractor used,the pto worked when I bought...
thetigr36
Site traffic
Boy, sure no traffic here. Walt Conner
tinkerer200
Does anyone else have this problem?
I have a Craftsman riding mower that the manual clutch...
cowgirlrose55
Briggs & Stratton OHV Intek Hard Starting
I am another of the seemingly many people fighting...
dreamoftheflood
John Deere Or Cub Cadet?
I'm going to buy a new lawn tractor this Spring and...
cbmullen
© 2015 Houzz Inc. Houzz® The new way to design your home™