Toro zero turn not starting after reversing battery polarity

ffb27August 6, 2014

I have a toro time cutter z4235 v-twin with a Kawasaki engine. I accidentally reversed the battery polarity when reconnecting my battery and realized it after my attempt of starting the mower. The issue now is that the mower will not start and every time I turn the ignition, the 30amp fuse breaks. I tried to replace the relay and still no luck with it. Every time the key is turned, a click is heard and the fuse is broken. Please help

Thank you for reporting this comment. Undo
tomplum

Unplug the engine harness, does it still pop the fuse? The most likely thing that was damaged would be the stator or regulator.

    Bookmark   August 6, 2014 at 9:12PM
Thank you for reporting this comment. Undo
ffb27

Where exactly is the engine harness? And do you mean the voltage regulator?

    Bookmark   August 6, 2014 at 9:27PM
Thank you for reporting this comment. Undo
tomplum

There will be a connector on the harness that comes out from under the engine shroud. Basically, you are physically eliminating circuits to determine which one is popping the fuse. there may be a diode in the harness to the PTO that popped too. What is the model number and first 3 digits of the serial off that silver tag ahead of the engine?

    Bookmark   August 8, 2014 at 7:33PM
Sign Up to comment
More Discussions
Briggs & Stratton OHV Intek Hard Starting
I am another of the seemingly many people fighting...
dreamoftheflood
Looking at a John Deere X300 to purchase
I sold my Power Kraft (finally) after a persistent...
Alberti
Dead cylinder
So I have a Briggs & Stratton Engine model number:...
RebornGreen
Tecumseh throttle governor help?
Ssnow blower, not tractor question, but I'm hoping...
mbsl98
Tuff Torq K46 Tranny
I've been reading many of the posts on this site and...
tuco
© 2015 Houzz Inc. Houzz® The new way to design your home™