White Out rosebush lost all petals

rafuscoJune 21, 2014

I planted a White Out Rose back in April. It did well and was full of blooms within about 6 weeks. We went on vacation for 5 days, during which temperatures here were in the low 80s with some rain. When we got home I noticed that every rose has lost its petals. I am wondering a) what happened and b) what I can do now. Should I deadhead what is there? I am a novice garder so I appreciate any advice.

Thank you for reporting this comment. Undo
michaelg(7a NC Mts)

Snip or break off the spent blooms. I would leave a few and see if they set hips (fruit). If this variety does not set hips, then there is no need to deadhead. (Hips consume energy that should be going into growth and more blooms). The plant will bloom again in six weeks,

    Bookmark   June 21, 2014 at 1:58PM
Sign Up to comment
More Discussions
Anyone have experience with baby romantica roses? I'm in zone 8.
Just came across Romantica roses - charming! I container...
salleygardens
When to remove winter protection so it doesn't rot, basically?
After last year's killing Polar Vortex, this winter...
meredith_e Z7b, Piedmont of NC, 1000' elevation
Roses, feeding an addiction......
I have been on a search for Peach Drift. I called...
Beth9116 zone 8a TX
blaze improved
Is blaze improved really zone 3 like HMF says it is???? What...
rosecanadian
To Pascali or not?
I'm contemplating planting a hedge of roses and my...
kublakan
© 2015 Houzz Inc. Houzz® The new way to design your home™