Enginegoes full throttle on start up

pat2350November 18, 2010

I have a Craftsman rear engine 10HP riding mower

Engine Model 143.98 1002

Family ttp358U/G2EA

It ran poorly when I got it - I cleaned the carburetor

I had the carburetor apart 5 or 6 times, never got it right

I bought a new carburetor - the engine now runs fine -however when I connect the governor linkage it goes to full throttle. I have tried every linkage hole onfiguration with no luck

I know it is a governor or linkage issue

I don't know how the governor is supposed to work

I'm not sure if the spring or linkage was correct when I got it or if the governor works at all. Can anyone get me to the next step. Thanks Pat

Thank you for reporting this comment. Undo
walt2002

The numbers you sent are not the model numbers of the engine. There is a shaft coming out the side of the engine that the governor arm attaches to. Loosen the clamp holding the arm to the shaft. Move the carb throttle to wide open position. Turn the shaft clockwise as far as it will go, hold both in this position and re-tighten the clamp with your third hand. :)

IF THIS DOESN'T HELP, then most likely the governor and OIL SLINGER assembly inside the engine are bad. NOTE: And Oil slinger.

Walt Conner

    Bookmark   November 18, 2010 at 12:59PM
Sign Up to comment
More Discussions
Looking at a John Deere X300 to purchase
I sold my Power Kraft (finally) after a persistent...
Alberti
Everybody getting enough seat time with the snow?
I know I am, way too much and compared to New England,...
exmar
Tecumseh throttle governor help?
Ssnow blower, not tractor question, but I'm hoping...
mbsl98
Snapper Riding Lawn Mower Wiring Diagram
I'm trying to find a wiring diagram for a Snapper Rear...
byrondallas
transmission clean and do not overwork
I have a Dumb question about that phrase. Exactly what...
krnuttle
© 2015 Houzz Inc. Houzz® The new way to design your home™