john deer l120 hard to start

eddier51(8)November 16, 2012

My John Deer l120 is hard to start,put in a new battery but it still acts like the battery is weak and will barely turn over especially if it is cold outside.I usually hook up the battery charger to it,but here lately that does'nt even work.Help Please!

Thank you for reporting this comment. Undo
bill_kapaun

I assume that's an L120?

Briggs OHV engines need to have the valves properly adjusted for the compression release to function properly.

There are numerous threads on that exact problem if you just scroll down a few threads/pages.

Walt Conner has a procedure that HE will send you if YOU email him, telling him what you want.
Look for his address in the mentioned threads.

    Bookmark   November 16, 2012 at 7:22PM
Thank you for reporting this comment. Undo
eddier51(8)

Thanks Bill appreciate the help

    Bookmark   November 17, 2012 at 9:07AM
Sign Up to comment
More Discussions
old mtd lawnflite chain drive?
Hey I just bought and old riding mower and lo and bohold...
mtdlawnflite
New Briggs & Stratton lawn mower engine never needs an oil change
Wonder what Taryl at the Grass Roots Garage would have...
txtom50
Everybody getting enough seat time with the snow?
I know I am, way too much and compared to New England,...
exmar
Request for advice/information on Simplicity Regent 4111
Hello all. I was doing an internet search and found...
mattyruch
Tuff Torq K46 Tranny
I've been reading many of the posts on this site and...
tuco
© 2015 Houzz Inc. Houzz® The new way to design your home™