Return to the Bulbs Forum | Post a Follow-Up

 o
Caladiums

Posted by drobertson_2008 8 (My Page) on
Tue, Apr 6, 10 at 12:26

I planted caladium bulbs 8 weeks ago and still do not see any signs of them coming up. I planted in flower beds as well as containers. Is this normal or did I do something wrong? I have never planted them before. Thanks for any help given.

Donna


Follow-Up Postings:

 o
RE: Caladiums

It's entirely possible that the ground has not warmed up enough. If I had planted caladiums here two months ago, it's entirely possible that they would have frozen and be mush. Caladiums are very sensitive to cold soil. Keep an eye on them, and maybe as the ground warms, they'll come on up. If they don't, you'll need to replant them when it's warmer. This probably isn't what you wanted to hear.....


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Bulbs Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here