Return to the Bulbs Forum | Post a Follow-Up

 o
King Alfred Daffodils: some bloom, some just foliage

Posted by wynswrld98 z7 WA (My Page) on
Tue, Apr 21, 09 at 23:19

I have planted a ton of mature King Alfred Daffodils on my property, some bloom and some just send up tall shoots but no blooms, I'm puzzled. For instance in one area I have 10 with tall shoots and no blooms then 8 on each side of them blooming although same lighting conditions, same mature bulbs. Similar things elsewhere on my property. We've had a very wet winter here in the Pacific Northwest so no moisture problems for sure.

On the ones that have shoots, the shoots are as tall as those that are blooming and they look very healthy.

Anyone have any theories?

The only thing I can figure is perhaps the soil isn't as full of nutrients in part of the soil here and there and I should try and add some nutrients to see if I can get them to all bloom next year?


Follow-Up Postings:

 o
RE: King Alfred Daffodils: some bloom, some just foliage

Where did you get the mature King Alfreds from?

Big box store? Ordered on line? From a friend/neighbor?

When were they planted? Month and year?

Sue


 o
RE: King Alfred Daffodils: some bloom, some just foliage

King Alfred is as fool proof as any plant I can think of. In my experience with new bulbs from a reliable source the flower is in the bulb and is not dependent on soil fertility to bloom. Bulbs stored in a refrigerator with a source of gas from ripening fruit can have the bloom damaged. The most common cause of failure to bloom of King Alfred is too much shade. Al


 o
RE: King Alfred Daffodils: some bloom, some just foliage

All of them bought from Lowes, all huge King Alfred Daffodil bulbs, bought and planted the past 3 years, always bought and planted in November.

What's making me wonder about nutrition in the soil is it's my understanding when I buy them (in Nov.) they already are pretty much pre-determined what they're going to do in spring since all nutrients they took in before they went dormant.

What patten I think I'm seeing is the bulbs that are 2-3 years old are the ones whereby some of them bloom and some don't. Regarding shade, I planted a whole bunch in the most shaded area on my property, more shaded than anywhere else I've ever planted them, planted them Nov. 2008 and they're blooming like crazy right now whereas some that were planted 2-3 years ago in full sun are not blooming although the foliage is tall and healthy looking.

The only thing I can figure is the soil doesn't have a lot of nutrients in it and the 2-3 year old planted bulbs didn't get enough nutrition in their growing season(s) to form flowers the next year. That's my only theory but am curious opinions. I'm considering in the fall digging up the ones that didn't bloom this spring and add compost to the soil to try and juice up the soil.

Open to opinions, thanks!


 o
RE: King Alfred Daffodils: some bloom, some just foliage

Thanks for the additional info.

What patten I think I'm seeing is the bulbs that are 2-3 years old are the ones whereby some of them bloom and some don't.
hmmmm....When you planted them, did you maybe plant them too close in a hole, that they might already be crowded? Once they become crowded, they will continue to split, and make new bulbs, but they then will all be too small to bloom. Another theory is that maybe there is some sort of an underground varmit that has tunneled under the bulb, where it was not getting good contact with the soil, but had enough anyway to survive and send up foliage. Is the ground maybe spongy in the area where they are not blooming?

I would pay particular attention to #9 and #11 at the link below. I'd be very temped to dig up a couple right now and try and see what is going on with them.

Another thing, could be #10 as you say the ones in the sun were the ones not doing as well as the shaded ones. Did the sun ones get ample moisture, or are they maybe in a much drier area of the property?

I hope you can get it solved...please keep us posted.

Sue

Here is a link that might be useful: Daffodils Not Blooming?


 o
RE: King Alfred Daffodils: some bloom, some just foliage

The critical thing with all daffodils is to ensure that the foliage is not removed until at least 6 weeks after the flowering is finished, that means if they are in grass not mowing the area they are in until after 6 weeks. If its done earlier, flowering will decline and eventually the bulbs will die too. They need this time to resorb the nutrients from the leaves to feed the bulb.

They will happily grow for years without added nutrient if they are given this time.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Bulbs Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here