Return to the Bulbs Forum | Post a Follow-Up

 o
Fall bulbs not flowering ... yet.

Posted by dirtgently 5a (My Page) on
Fri, Nov 12, 10 at 12:22

I planted a handful of Sternbergia lutea, saffron crocus, and Crocus speciosus in a cedar container on my balcony at the beginning of September. All of them sprouted in mid to late October, but only the C. speciosus has bloomed (and only begun blooming last week).

Around here, I'm told that they should've started blooming almost a month ago ... so I'm just curious if the saffron and S. lutea will bloom at all this season, and if there's anything that I can do to encourage them to do so.

Photobucket

Balcony gets full sun all day and is pretty sheltered. Temperatures have been hovering between -2�C and 10�C lately, with stretches of really sunny days and rainy November days.

And yup, it looks pretty much like I planted the bulbs in a straight line, but I really did stagger them! I guess they can pull themselves around underground after they're buried.


Follow-Up Postings:

 o
RE: Fall bulbs not flowering ... yet.

I don't see any foliage for the saffron crocus. Sometimes they don't bloom the first year they are planted. You may have to wait until next year for them to bloom.


 o
RE: Fall bulbs not flowering ... yet.

  • Posted by socalgal USDA z10 Sunset z24, (My Page) on
    Sat, Nov 13, 10 at 0:40

Some of my Sternbergia didn't bloom the first year.


 o
RE: Fall bulbs not flowering ... yet.

@socalgal: that's disappointing. Is it just because they're unhappy about being dug up and transplanted? I was planning on moving them around a bit next August.

@wvbetsy: the saffron crocuses are there, I think, if they look like the green bits on the left:

Crocus?


 o
RE: Fall bulbs not flowering ... yet.

  • Posted by socalgal USDA z10 Sunset z24, (My Page) on
    Sat, Nov 13, 10 at 9:40

I don't know why some Sternbergia didn't bloom the first year, this was my first experience with them. They did bloom this year.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Bulbs Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here