Return to the Container Gardening Forum | Post a Follow-Up

 o
What is on my soil??

Posted by greybird_keke (My Page) on
Mon, Apr 29, 13 at 21:10

Today I unpotted my rhizomatous begonia to find this...I assume it is some sort of fungus due to my overwatering. Although it looks white in the photo, it is actually yellow, and appeared to be only on the outside of the rootball. I removed as much soil as I could, and the plant was repotted in gritty mix. I hope it isn't too late for it....it was a beautiful plant last fall!


Follow-Up Postings:

 o
RE: What is on my soil??

It looks like mold to me & I do hope you can save it, do the rhizomes feel mushy or hard ?

Where are you Al?? Your help is needed !!!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Container Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here