Return to the Container Gardening Forum | Post a Follow-Up

 o
Potted Marigolds

Posted by june81948 z6 MA (My Page) on
Wed, Aug 3, 11 at 20:19

the marigolds that I planted in my island garden are doing well, but the ones I planted in pots are doing terrible. They have buds but they are all dead and dried up when they open. Even the stalks (foliage) looks dried up. I water daily and feed occasionally but they still look terrible.


Follow-Up Postings:

 o
RE: Potted Marigolds

  • Posted by tapla z5b-6a mid-MI (My Page) on
    Wed, Aug 3, 11 at 21:01

Could be any one of a number of reasons. High on the lengthy list of possible suspects is over-watering, perhaps due to a heavy soil, or spider mites, which often find the plant very attractive.

Al


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Container Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here