Return to the Container Gardening Forum | Post a Follow-Up

 o
Weird Star Jasmine Bloom

Posted by jbw1984 SoCal 9 (My Page) on
Sun, Nov 17, 13 at 21:49

Hello everyone,

I have a potted star jasmine plant that is on my south-facing balcony. I repotted it in May while it was in bloom and after losing the flowers in June, it grew all the way up a 6-foot trellis in the month of August. (Yes, in 4 weeks.)

I water the plant whenever the soil gets dry, which ends up being at least a third of a gallon every couple of days now that the temperatures are a little cooler. It is in a pretty deep 14" container.

Anyway, one of the branches (a new growth) made flowers this week. None of the others did.

Am I doing something wrong, or right? I did not expect to get a weird late autumn bloom; I though this plant blooms in the spring?


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Container Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here