Return to the Fruit & Orchards Forum | Post a Follow-Up

 o
Plum tree late this year

Posted by redherring89 CA (My Page) on
Wed, Apr 16, 14 at 22:15

I have a Santa Rosa plum tree in LA/24 that usually blooms in March and starts filling out with leaves in April. But this year I have seen no blooms and have only a few leaves. It appears healthy (alive, no pests, no lesions), and I watered it weekly during this winter's drought. Anyone else having this problem? What could it be?


Follow-Up Postings:

 o
RE: Plum tree late this year

  • Posted by fruitnut z7b-8a,4500ft SW TX (My Page) on
    Wed, Apr 16, 14 at 22:20

Possibly not enough chilling. It was a warm winter in CA. If that's the issue it might not bloom but should eventually put out enough leaves to survive.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fruit & Orchards Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here