Return to the Fruit & Orchards Forum | Post a Follow-Up

 o
Spots on Serviceberry Leaves

Posted by Bradybb wa 8 (My Page) on
Thu, Jun 14, 12 at 14:53

I have a small Serviceberry that was planted last Fall and is growing well,but has developed spots on the outer edges of some leaves.Has anyone seen this before?Is it rust?Thanks for any info. Brady


Follow-Up Postings:

 o
RE: Spots on Serviceberry Leaves

My guess would be Entomosporium leaf spot, but I'm not a plant pathologist.
I've probably seen it on mine, and not really paid any attention to it. Majority of leaf mass looks fine, I doubt that it's causing any significant issue for the plant.


 o
RE: Spots on Serviceberry Leaves

The way that pattern squiggles around, leaf miners are a possibility.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fruit & Orchards Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here