Return to the Fruit & Orchards Forum | Post a Follow-Up

 o
Peach problem?

Posted by Flying_C 6a (My Page) on
Tue, Oct 23, 12 at 11:08

Hi everyone!

I planted a dwarf peach (Red Haven, I think) this past spring, and I've just noticed a red blob thing on the trunk. I've done some googling but haven't managed to find anything that looks like it - maybe I'm not using the right terms. Can someone help me ID this, please?

Thanks for any help!


Follow-Up Postings:

 o
RE: Peach problem?

  • Posted by fruitnut z7b-8a,4500ft SW TX (My Page) on
    Tue, Oct 23, 12 at 11:33

It looks like crown gall which usually doesn't occur much above ground but can. It's probably something else but whatever it is I'd probably cut it off.


 o
RE: Peach problem?

It sure looks like a fungal-type growth that is caused by damp weather. I would spray it with a fungal spray (maybe after cutting the bulk out, without damaging the tree).


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fruit & Orchards Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here