Return to the Garden Photo Gallery Forum | Post a Follow-Up

 o
Oakleaf Hydragea Flower has mold

Posted by helengh GA (My Page) on
Sun, Jun 15, 08 at 16:37

My two beautiful Oakleaf Hydrangeas blooms have a lot of mouldy looking stuff in them, the bloom snaps off if touched and some have broken in half.
What is the problem. The leaves look fine, although you can see where this mould stuff has washed down onto them.
Can someone help me to save them.
thanks


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garden Photo Gallery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here