Return to the Garden Photo Gallery Forum | Post a Follow-Up

 o
Sick Exbury Azalea

Posted by fireweed_1947 Port Orchard,Wa (My Page) on
Sun, Sep 27, 09 at 15:32

Hello. My exbury is next to a fairly new concrete foundation(3 yrs) so may be iron chlrosis but may also be Nitrogen deficiency? Took these pics today so they may only show fall color change but a month ago the leaves were very yellow and many had very thin - 1/8 to 1/16" dark red margins. Have not tested soil. What should I do first? Is it too late this year to add nutrients?

Image link: Sick Exbury Azalea (24 k)


Follow-Up Postings:

 o
RE: Sick Exbury Azalea

They do not like to bake in the sun.....is it in part shade?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garden Photo Gallery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here