Return to the Garden Photo Gallery Forum | Post a Follow-Up

 o
Tibochina Urvilleana in bloom-photos

Posted by central_cali369 z9 CA (My Page) on
Thu, Dec 20, 07 at 19:08

My tibouchina (Princess flower) has been in bloom since October, but i hadnt taken pictures. I took these this morning, some of them are kind of blurry but they are an attemp at capturing the vivid purple color. The actual color is different than what is shown here. Also, these are not photoshopped (in other words, i have not adjusted the color levels on my computer). enjoy.

Red flower buds and a couple of blooms

Another shot

the purple contrasts nicely with the green


Follow-Up Postings:

 o
RE: Tibochina Urvilleana in bloom-photos

The leaves are so colourful it would still look good without flowers.
Bill


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garden Photo Gallery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here