Return to the House Plants Forum | Post a Follow-Up

 o
Jasminum polyantha

Posted by JoshTx 8a (My Page) on
Thu, Mar 13, 14 at 16:44

I purchased a jasmine plant this week from Home Depor (I should know better) that was in full bloom. It's started to grow some, but the whole bush doesn't seem happy. It's lower leaves are dry and crunchy, and the new growth has started look pretty sad. I did water it once (lightly and only the top inch of the soil, in an effort to alleviate this) but I may have made it worse. Its blooms are falling off and the new blooms are starting to look like they might jump ship.

Any ideas?

Thanks!

Josh


Follow-Up Postings:

 o
RE: Jasminum polyantha

I think we can help better if you can provide a photo
Thanks-


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the House Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here