Return to the House Plants Forum | Post a Follow-Up

 o
Help with Rubber Plant please!

Posted by meg223 none (My Page) on
Mon, Mar 18, 13 at 20:53

Does anyone know what is causing this to happen to the leaves of my rubber plant? It looks like the surface is being eaten (or maybe reacting from too much sun/cold?) and there is little black dots on the surface. This plant is kept in our sunroom by the window and it gets fairly cold in here in the winter. Any suggestions would be much appreciated!!


Follow-Up Postings:

 o
RE: Help with Rubber Plant please!

I'm no expert by any means but just a question:

Have you washed the plants leaves with anything besides water?


 o
RE: Help with Rubber Plant please!

You may want to investigate thrips to see if that's a match to the condition.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the House Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here