Return to the House Plants Forum | Post a Follow-Up

 o
please help my spider plant!!

Posted by jake579 none (My Page) on
Mon, Oct 7, 13 at 19:53

I bought this spider plant a few months ago and it has been a downhill expierence since the day I brought it home. the leaves have been browning along with the stallons and babies. I give it water when it starts to dry out but not completly dry as I was told it likes to be kinda moist. its in a rather sunny window so I'm not sure what's going on with it but she is not happy lol please help! I had another picture but the site would not let me upload


Follow-Up Postings:

 o
RE: please help my spider plant!!

Looks like a transplant is an order. Is this an exotic angel plant? How did it look when you bought it? If I were you I'd take it out of its pot and have a look at the roots, if it's completely pot bound get a new hanging basket and transplant. If the roots look damaged I'd take away the old soil and repot in the same pot with fresh soil after having trimmed off the dead stuff. Also the soil looks moldy. Is there air circulation where you have placed the plant? Is your water hard? Have you been fertilizing it? How often do you water? To me, it seems something is wrong with the soil.


 o
RE: please help my spider plant!!

I think the info here may helpful to you. That 'soil' looks like it is suffocating/rotting the roots.


 o
RE: please help my spider plant!!

It does look like it but when I changed the dirt the roots were all still white and fat. it was a bad batch of dirt, I had other plants grow the white stuff on top too.I had repotted it the first time I gave it a hair cut And I guess that didn't help it any. thank you for the link purpleinopp!


 o
RE: please help my spider plant!!

Do you water in sips and have you fertilized it? How much water and fertilizer and how long between waterings?

Is that mold on top?

MIke:-)


 o
RE: please help my spider plant!!

I give it roughly a cup and half of water every few weeks if the soil feels dry...I think it was mold on top the bag of dirt was only a couple months old. I don't fertalize because I put it into some miracle grow....bad choice? Thank you all for your help it is much appreciated!!!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the House Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here