Return to the Lawn Mowers Forum | Post a Follow-Up

 o
Blower belt

Posted by cavell none (My Page) on
Mon, Jan 7, 13 at 12:39

My snowblower has never thrown snow very far. I replaced the impeller belt with a new belt and adjusted the tension so at idle, the impeller actually spins very slowly. I engage impeller using handle lever and impeller certainly spins fast but the machine still throws snow very poorly. Motor runs great, idles fine, no surging or anything. Motor is fine. What's up with crappy throwing? It's a 7hp, 24 inch cut 2 stage unit.


Follow-Up Postings:

 o
RE: Blower belt

See your post at the Tool Shed.I answered it there.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here