Return to the Lawn Mowers Forum | Post a Follow-Up

 o
B&S Push mower troubles

Posted by tnshooter83 (My Page) on
Wed, Apr 14, 10 at 1:02

I mow my Grandmothers lawn, and she has a B&S 4hp push mower.
I don't currently have a model or any number.

I can get the mower to run, but it involves a few odd steps.

1. To get it started you have to prime the carb by pressing in on the bulb.
I normally press it in 6-10 times.

2. Pull the starter rope until it act like it "might" run. Then prime it for 6 more pumps of the bulb.

Next is the tricky part, you have to pull the starter rope until the mower run.
Then very quickly you have to keep pressing the prime bulb to keep it running. (all while holding down the throttle handle)
After about a minute, it will then all of a sudden start wanting to die if when you press the bulb.

Then, and only then will it stay running. It will run "ok" but not with the power it "should" have as if it were working properly. Then all of a sudden it will die, and you have to repeat the starting process all over again.

Any ideas? I'm figuring it is a carb problem. Are the carb on these things hard to rebuild?


Follow-Up Postings:

 o
RE: B&S Push mower troubles

  • Posted by baymee LehighValleyPA (My Page) on
    Wed, Apr 14, 10 at 11:13

I believe you have a carb mounted on top of the gas tank with 5 screws. Buy yourself a tank diaphragm kit, about $6, and replace the diaphragm.

Remove the tank bolts and the governor lever from the carb, remove the screws, lift up the carb, replace the gasket and rubber diaphragm, re-install the carb. If the primer bulb doesn't have holes in it, keep it, or replace it. Everything should be self-explanatory and easy to do.

It should not be necessary to push the primer bulb more than 3-5 times. With a new diaphragm, maybe twice is enough.


 o
RE: B&S Push mower troubles

Also check your air filter. That may be keeping the carb. from working properly.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here