Return to the Lawn Mowers Forum | Post a Follow-Up

 o
Craftsman Push Mower

Posted by ksrjreed1 (My Page) on
Sat, Apr 17, 10 at 12:41

I have a Craftsman push mower that I have owned for roughly four years and have had the same problem for four years, everytime I start it up it starts up fine then dies out of no where, if you keep pushing the primer button it will stay on but you let off of the primer the mower loses power and slowly dies, what could be going wrong and what do I need to do to fix it. Thanks.


Follow-Up Postings:

 o
RE: Craftsman Push Mower

  • Posted by baymee LehighValleyPA (My Page) on
    Sun, Apr 18, 10 at 6:28

Check the main jet for varnish in the holes. Clean with a fine wire and carb cleaner. If that doesn't fix it, you have varnish in your carb. If your carb is mounted on top of the gas tank, you need a new diaphragm.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here