Return to the Lawn Mowers Forum | Post a Follow-Up

 o
Honda Lawnmower

Posted by beapainter Kansas (My Page) on
Sun, Apr 18, 10 at 13:38

I own a Honda hra214. The mower has a slow and fast speed that is activated by a lever on the mower deck. My problem is that transmission will not stay engaged in fast. What happens is when I engage the blade the speed lever will pop out of fast between the two speeds. If I put the lever in fast and not engage the blade, the mower will travel in fast until I engage the blade. Anyone have any ideas?


Follow-Up Postings:

 o
RE: Honda Lawnmower

  • Posted by canguy British Columbia (My Page) on
    Sun, Apr 18, 10 at 15:36

That is an older unit, the dogs on the gear inside the transmission may be worn. If you are not familiar with Honda mowers take it to a shop that is. It is a fairly involved job.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here