Return to the Lawn Mowers Forum | Post a Follow-Up

 o
Craftsman push mower low rpm

Posted by blar2005 43065 (My Page) on
Mon, May 10, 10 at 15:26

Had my Craftsman push mower (6.75HP mulcher) for about 8 years and while recently mowing under a tree the mower coughed and died. Restarted fine, but now the engine runs like a 2.5 HP mower and does not have the same power it had. Checked the plug - clean. Oil good. Gas fine. Under the mower there is no obstruction around the blade or shaft. It starts up and runs fine, but seems to have alot less rpm's. Checked the throttle - maxed out. Air filter good. Any thoughts?


Follow-Up Postings:

 o
RE: Craftsman push mower low rpm

Governor linkage may have been bent by a branch under the tree.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here