Return to the Lawn Mowers Forum | Post a Follow-Up

 o
push mower wont start after new crankshaft, spark fine..

Posted by rstregooski (My Page) on
Tue, Jun 29, 10 at 17:55

Hello all.. I recently replaced the crankshaft + key on a 5 year old briggs engine from my push mower. Granted it was the first time I've done a crankshaft, but I did all the research and put everything back together exactly. Now I can't get it to start- sparks fine, carburetor / tank clean, clean gas, oil level check. The flywheel engages the shaft fine, but no combustion. I'm pretty stumped on this one, it's probably something real obvious! If anyone has any ideas I'd be very grateful, thanks a lot..


Follow-Up Postings:

 o
RE: push mower wont start after new crankshaft, spark fine..

Are you getting gas through the carb? If so, recheck the valve timing.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here