Return to the Lawn Mowers Forum | Post a Follow-Up

 o
Toro/Suzuki 2Cycle Commercial Mower 2001

Posted by Tim62 none (My Page) on
Tue, Jul 9, 13 at 16:42

Mower will not start the last time started made a clanking sound when first started then leveled out after mowing lawn would not start again and the crank is hard to pull. Pull the plug and it will crank easy. Checked out engine and everything looks good, cleaned Muffler and Exhaust Port. Put everything back together with spark Plug in want start and is hard to crank.


Follow-Up Postings:

 o
RE: Toro/Suzuki 2Cycle Commercial Mower 2001

It should have a blade safety brake that stops the engine when you let go of the engine control bail. Any chance the cable broke or the brake is otherwise engaged?


 o
RE: Toro/Suzuki 2Cycle Commercial Mower 2001

The Brake and cable are good, it will crank easly with sparkplug out.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here