Return to the Lawn Mowers Forum | Post a Follow-Up

 o
Briggs Engine problem

Posted by RAILDATA none (My Page) on
Mon, Jul 23, 12 at 21:12

I have a 6 year old Briggs 17.5 hp lawnmower engine #31C7070154E1 with Nikki vert shaft carb. Had mowed 15+ minutes with no problem when it just stopped. Now will start and run 2-3 minutes when cold & momentarially afterwards, Replaced plug & fuel filter and notice filter seems to have a very low level of fuel showing after a minute or two. Will run regardless as long as I inject carb cleaner. Same problem with ground disconnected. Breather hole in fuel tank cap is clear.

Sounds like a carb problem. Do I need to rebuild it or is there a possibility of something else?

Thank you for any help you can provide.

Allen S


Follow-Up Postings:

 o
RE: Briggs Engine problem

Check to see if the solenoid on the bottom of the carb is working. Does it click when you turn the key on?

Walt Conner


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here