Return to the Lawn Mowers Forum | Post a Follow-Up

 o
Repost from Tools: Brand new generator won't run without choke o

Posted by baymee LehighValleyPA (My Page) on
Mon, Oct 29, 12 at 5:18

Customer dropped off a brand new generator. Just put in fresh gas and it won't run on anything but "Choke".

First thing was to check for water in the bowl. No.

Removed the carb. Took it apart and checked all the jets for dirt. None found.

Even though it's under warranty, we are going to take a direct hit from Hurricane Sandy tomorrow, so forget about replacing it. There are none and the electric might be out for several days or more.

Checked the plug. Sooted. Expected that because it only runs on choke position.

As soon as you try to open the choke, even slightly, it stalls.

Does not respond to carb cleaner in the throttle, at all. Usually if the jets are blocked, it will at least have some response to carb cleaner. No response at all.

Has compression. Can feel the resistance at TDC.

I don't suspect the carb, but what else would cause this?

I think it's a Chonda engine.


Follow-Up Postings:

 o
RE: Repost from Tools: Brand new generator won't run without cho

Remove the gas cap and see what happens.


 o
RE: Repost from Tools: Brand new generator won't run without cho

Did you remove the jet from inside the stem and clean? Or maybe have a Honda carb to try? Throttle plate open when it should be? It is a bit scary that this has never really run. If you are confident in the carb, the first thing to check would be the flywheel key, the second valve lash and timing. Hopefully it is similar enough to a GCV in design.


 o
RE: Repost from Tools: Brand new generator won't run without cho

  • Posted by baymee LehighValleyPA (My Page) on
    Mon, Oct 29, 12 at 14:50

I took the jet out and it was open. I just got a second Generac, identical to the first and from the same source (a local electrical supply company). It has the same problem.

The boss called Generac and they said that sometimes they have had a problem where the governor lever nut comes loose and the lever doesn't function. I manually moved the throttle, but there was no response at all.

So still not sure what might cause the problem I've had. It's coming back tonight for a second look.


 o
RE: Repost from Tools:: Brand new generator won't run without ch

  • Posted by baymee LehighValleyPA (My Page) on
    Mon, Oct 29, 12 at 16:18

Update. The generator was just back in the shop. It started up on the first pull and ran perfectly for 5 minutes while I looked at the other one. I turned it off. One minute later, I tried to start the first generator, just to insure it would restart, and now we're back to the original problem. Starts on choke only and dies as soon as you open the choke.

Gas cap was vented. Governor lever is tight on the shaft, but anyway, it ran perfectly for 5 minutes. Plenty of gas in the tank and fuel bowl.


 o
RE::: Repost from Tools: Brand new generator won't run without c

  • Posted by baymee LehighValleyPA (My Page) on
    Mon, Oct 29, 12 at 17:57

Looked at the second twin generator. Same problem. Won't even attempt to start. Valves visually seem to open and close at the right times. Top of piston looks like it wasn't machined after it came out of the foundary mold.

Spark looks good in the tester; fuel is clean, fresh. Doesn't respond to carb cleaner spray or manual opening of the throttle.


 o
RE: Repost from Tools: Brand new generator won't run without cho

Could there be a leak between the carburetor and the engine? Perhaps they failed to install the gasket at assembly.


 o
RE: Repost from Tools: Brand new generator won't run without cho

Do you think that this could be one of Generac's own engines? Do you have a Generac model #? Is there an oil shut off module? Honda's are kind of a rounded rectangular piece hooked into the kill wire. Or maybe a simple switch?
I have also seen small OHVs having issues w/ the valves sticking. They tend to do this due to the light valve springs and tighter tolerances from being new. Add a touch of varnish like deposits from the poorly treated factory fuel and there could be your variable. They sometimes won't run, or if they do- can't close the valve fast enough so it can't breath. Like a plugged muffler. The extra fuel and bursts of carb spray really can't burn off. I tend to try and work carb spray down along the stem, then Seafoam or marvel.


 o
RE: Repost from Tools: Brand new generator won't run without cho

  • Posted by baymee LehighValleyPA (My Page) on
    Thu, Nov 1, 12 at 5:10

Finally, electricity and internet back up. Good job PP&L.

The twins use a UP170 model motor. It turned out that tomplum's thought on the low oil shut-off module was right. Unplugged the wire and both run perfectly. Faulty module.

Thanks for the help.


 o
RE: Repost from Tools: Brand new generator won't run without cho

where would that low oil wire be located? my nighbor bouught a cenerac at lowes ran it one day next day was running & just stopped .GAS &oil okay valves moving .cant even locate plug.


 o
RE: Repost from Tools: Brand new generator won't run without cho

  • Posted by baymee LehighValleyPA (My Page) on
    Tue, Nov 6, 12 at 17:48

You'll see the single wire coming out of the block, probably near the oil-fill plug. It's probably the only wire you'll see coming directly out of the sensor, screwed into the block.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lawn Mowers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here