Return to the Orchids Forum | Post a Follow-Up

 o
first time bud, but problems???

Posted by gregbr549 North Alabama (My Page) on
Sun, Jan 29, 12 at 14:39

Hi,
I have my first orchid that is about to bloom (I hope). It is a phalaenopsis. This bloom has been the same size for several weeks. The bud is about the size of an almond in the shell. Is there something wrong? Do buds usually take this long to bloom? Do I need to do something differently to make it finish blooming?
thanks for any help,

Greg


Follow-Up Postings:

 o
RE: first time bud, but problems???

Hi,congratulation on getting your first orchid,orchids are slow growers and therefore require patients,once the plant is healthy and getting enough sun,water and fertilizer it will eventually bloom,I have had phals send out a spike stop,and sent out a different spike which grows bloom and then the first spike then finish grows and then blooms,so don't worry just continue to cear your plant,I hopes this makes you feel better,happy growing,maybe a senior member could also shead some light.


 o
RE: first time bud, but problems???

I recently had my first chute and blooms for a phal! I was a little disappointed myself when I first got it it had 6-7 flowers but only 3 this time.... Got on the google and learned there is a bloom booster fertilizer for once A month use and will be starting that upon the flowers exit. The bud size was similar in the almond size but it opens up I am attaching a pic for you! It is kept outside.


 o
RE: first time bud, but problems???

You don't need bloom booster for anything. As long as the plant gets the right light, watering and warmth you will get blooms. Phals need a temperature drop in the Fall to initiate spikes.

Jane


 o
RE: first time bud, but problems???

  • Posted by arthurm Sydney, NSW AUST (My Page) on
    Sun, Apr 14, 13 at 0:37

There is a lot of information in past threads about bloom booster. Just put Bloom Booster in the search box at the top of this discussions page to find.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Orchids Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here