Return to the Orchids Forum | Post a Follow-Up

 o
Please help my Orchid! Photo included.

Posted by mrshefe Southern Cali (My Page) on
Mon, Apr 20, 09 at 0:53

I know nothing about orchid care. I got this as a gift for mother's day (as they are my fav) and I can't seem to get it to bloom! I think Orchids are seasonal? But, now should be the time it would bloom. The stick is completely dry and breaks (snaps off) very easily. The plant part at the bottom however seems very healthy. I water once a week, I have been using an orchid food also, and nothing seems to work ...is it dead? It is not placed in direct sunlight.

Please help!?

Thanks in advance,
Jen

Here is a link that might be useful: Photo of possibly dead Orchid


Follow-Up Postings:

 o
RE: Please help my Orchid! Photo included.

Your phal looks healthy and is finished flowering. Cut off the dead spike and let the plant grow new leaves and roots. It will flower again.

I would also suggest more sunlight as the leaves look dark.

Jane


 o
RE: Please help my Orchid! Photo included.

Your orchid is fine, the only thing that is dead is the old flowering spike. Cut it off at the base. You have to provide conditions that will encourage the plant to commence growing a new spike.

Perhaps the plant is not getting enough light and temperature variation.

Some light reading in the link. If you can give further details about where the plant is growing/watering/how far from window/fertilizer and so on, more info. will come from other forum members.

Here is a link that might be useful: Garden Forum FAQ.


 o
RE: Please help my Orchid! Photo included.

Hello, I just move from Puerto Rico were I used to have orchids to Chicago.I was so home sick that my partner bought me an orchid...I don't know whats wrong, I was just in the kitchen making tea and the leaves on my orchid turned yellow, as though they were steamed or something...I have no clue whats wrong. The are yellowish but its only one or two leaves. Also the flower buds are falling off without explination....please, please help me!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Orchids Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here